25 seconds problem!

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

25 seconds problem!

Dobbin Allan-r11834
I am posting this mail for Vijay since he was unable to get through
for some reason.

Vijay - you should look at the following:

1) HRESET to see if the part is getting reset. This could indicate
the watchdog is kicking in after 25seconds.

2) Examine the reset status register to see what the reset source was.

3) Look at CLKOUT relative to POR and HRESET as an indication of PLL
status.

4) temporary comment any startup code you have that waits for PLL to
lock to see if that is the cause of delay.

5) ENGCLK - what you describe sounds like your s/w must have ran and
changed sysclk to 40MHz but doesn't get as far as changing the ENGCLK
from default /64 to /1 (which I presume your s/w does at some point).

Regards,
Allan

-------------------attached msg from Vijay--------------
Hi Allan
        I have a strange problem. If you remember I had explained
earlier about our project we are trying to develop an MPC565 board
for Gas Engine ignition management. Our first prototype worked fine
but this new prototype has a problem. After board is powered up
for "25 seconds" the MPC565 does nothing then normal execution from
my firmware resumes. I use the TouCAN,QADC,QSMCM,TPU and it is single
chip configuration. There are no special options, I am just using it
with defaults. I checked my firmware operation it works fine after 25
seconds. I checked the RCW, crystal, POR etc and I am unable to track
the cause of this problem.
 The interesting thing is the processor always sleeps for 25 seconds
and during that time the engclk is 40MHz/64 and once it starts
executing it goes back to 40MHz.My part number is MPC565CZP40. So my
question is why is there such a large delay in execution and
what is the cause of it? What is puzzling is that there are no
changes between the two boards on the processor side yet we have this
problem.
I tried posting my message on the group but it somehow doesnt get
through? and I checked the archives nobody had this problem before.
Can you please provide me some pointers regarding this. I appreciate
your help.

Thanks& Regards
Vijay Lakshminarayanan





-----------------------------------------------------------
To learn more about Freescale Microcontrollers, please visit
http://www.freescale.com/mcu


 
Yahoo! Groups Links

<*> To visit your group on the web, go to:
    http://groups.yahoo.com/group/MPC500/

<*> To unsubscribe from this group, send an email to:
    [hidden email]

<*> Your use of Yahoo! Groups is subject to:
    http://docs.yahoo.com/info/terms/