Working Windows build?

classic Classic list List threaded Threaded
28 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Working Windows build?

Nikolas Becker
Hello everyone,

I just wanted to ask if there is a newer compiled windows version of the Ethernut configurator and the other tools included. I tried a whole day now trying to compile it via MSYS2 but was not able to produce a working version. All builds I can find (sourceforce, Ethernut.de) seem pretty much outdated.

Best regards,
   Nikolas
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes

Nikolas Becker writes:
> Hello everyone,
>
> I just wanted to ask if there is a newer compiled windows version of
> the Ethernut configurator and the other tools included. I tried a
> whole day now trying to compile it via MSYS2 but was not able to
> produce a working version. All builds I can find (sourceforce,
> Ethernut.de) seem pretty much outdated.

Did you try the cmake build setup as found in svn head?

Otherwise I can try to crossbuild. You proabably want win64?
The files are large unstripped, should I strip?
Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Nikolas Becker
Hi Uwe,

yes I took a copy from SVN head and tried cmake. Several librarys were missing, I installed them (one was a rather old one last updated 2011, I think it is a table display library). Then I had some real compiler errors and tried to bugfix them directly in the code and ended only compiling the nut configurator. After being able to compile it, it directly crashes from the start, that's where I stopped.
I would be really happy if you would produce a win64/win32 version (your choice). Stripping would be nice.
Thanks in advance!
Bye,
  Niko


-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von [hidden email]
Gesendet: Donnerstag, 12. März 2020 12:29
An: Ethernut User Chat (English) <[hidden email]>
Betreff: Re: [En-Nut-Discussion] Working Windows build?


Nikolas Becker writes:
> Hello everyone,
>
> I just wanted to ask if there is a newer compiled windows version of
> the Ethernut configurator and the other tools included. I tried a
> whole day now trying to compile it via MSYS2 but was not able to
> produce a working version. All builds I can find (sourceforce,
> Ethernut.de) seem pretty much outdated.

Did you try the cmake build setup as found in svn head?

Otherwise I can try to crossbuild. You proabably want win64?
The files are large unstripped, should I strip?
Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 --------- _______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
Nikolas Becker writes:
> Hi Uwe,
>
> I would be really happy if you would produce a win64/win32 version
> (your choice). Stripping would be nice.
> Thanks in advance!
I have put them on tools/binaries/x86_64-w64-mingw32.

nutconfigure starts in wine, qnutconf has dependancies not statified
in my wine incarnation. I list the needed dll in Readme.md

Please report back.

Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Nikolas Becker
Hi Uwe,

Thanks!
I downloaded all the needed dlls (another one was missing: libwinpthread-1.dll). Now it tries to start but I get a similar error like when I tried to compile it myself:
qnutconf.exe - Anwendungsfehler
Die Anwendung konnte nicht korrekt gestartet werden (0xc000007b). Klicken sie auf "OK", um die Anwendung zu schließen.

Any ideas?

Bye,
   Niko

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von [hidden email]
Gesendet: Donnerstag, 12. März 2020 13:48
An: Ethernut User Chat (English) <[hidden email]>
Betreff: Re: [En-Nut-Discussion] Working Windows build?

Nikolas Becker writes:
> Hi Uwe,
>
> I would be really happy if you would produce a win64/win32 version
> (your choice). Stripping would be nice.
> Thanks in advance!
I have put them on tools/binaries/x86_64-w64-mingw32.

nutconfigure starts in wine, qnutconf has dependancies not statified in my wine incarnation. I list the needed dll in Readme.md

Please report back.

Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 --------- _______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
Nikolas Becker writes:

> Hi Uwe,
>
> Thanks!
> I downloaded all the needed dlls (another one was missing:
> libwinpthread-1.dll). Now it tries to start but I get a similar
> error like when I tried to compile it myself:
> qnutconf.exe - Anwendungsfehler
> Die Anwendung konnte nicht korrekt gestartet werden
> (0xc000007b). Klicken sie auf "OK", um die Anwendung zu schließen.
>
Very helpfull message...

https://www.borncity.com/blog/2018/09/01/windows-10-fehler-0xc000007b/
implies that either the qnutconf image is invalid or probably some of
the dll. As you told before, some things you downloaded where ages
old. Recheck carefully!

Please also state if nutconfigure works! And if it already worked when you
compiled it.

B.t.w. is WSL an option for you?

Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Dušan-2
Hi Uwe and Becker,

I am still using the old nutconf.exe for creating nutbld file structure.
It can be downloaded from nutconf.exe
<http://www.solarmonitor.cz/download/public/NutOS/nutconf.exe> link, the
md5 is for checking file contents.
Please let me know, if it works.

Dušan

On 12.3.2020 15:05, [hidden email] wrote:

> Nikolas Becker writes:
>> Hi Uwe,
>>
>> Thanks!
>> I downloaded all the needed dlls (another one was missing:
>> libwinpthread-1.dll). Now it tries to start but I get a similar
>> error like when I tried to compile it myself:
>> qnutconf.exe - Anwendungsfehler
>> Die Anwendung konnte nicht korrekt gestartet werden
>> (0xc000007b). Klicken sie auf "OK", um die Anwendung zu schließen.
>>
> Very helpfull message...
>
> https://www.borncity.com/blog/2018/09/01/windows-10-fehler-0xc000007b/
> implies that either the qnutconf image is invalid or probably some of
> the dll. As you told before, some things you downloaded where ages
> old. Recheck carefully!
>
> Please also state if nutconfigure works! And if it already worked when you
> compiled it.
>
> B.t.w. is WSL an option for you?
>
> Bye
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
Dušan writes:
> Hi Uwe and Becker,
>
> I am still using the old nutconf.exe for creating nutbld file structure.
> It can be downloaded from nutconf.exe
> <http://www.solarmonitor.cz/download/public/NutOS/nutconf.exe> link, the
> md5 is for checking file contents.
> Please let me know, if it works.
Dusan,

I think recent nutconfigure has much better defaults. Svn head relies
on ne features introduces.  So the nutconfigure I produce shoudl be
the first choice.

Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Dušan-2
Uwe,

maybe I will try sometime.

This utility works for me even with the new conf files.

Recently, I was asked to fix a firmware for a 15 years old designs.
And the Nut for it is without a configurator, no nutbld structure,
output goes to source directories.
Do you remember these times :-)?

Dušan

On 12.3.2020 16:47, [hidden email] wrote:

> Dušan writes:
>> Hi Uwe and Becker,
>>
>> I am still using the old nutconf.exe for creating nutbld file structure.
>> It can be downloaded from nutconf.exe
>> <http://www.solarmonitor.cz/download/public/NutOS/nutconf.exe> link, the
>> md5 is for checking file contents.
>> Please let me know, if it works.
> Dusan,
>
> I think recent nutconfigure has much better defaults. Svn head relies
> on ne features introduces.  So the nutconfigure I produce shoudl be
> the first choice.
>
> Bye
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
Dušan writes:
> Uwe,
>
> maybe I will try sometime.
>
> This utility works for me even with the new conf files.
>
Did you try on STM32?

> Recently, I was asked to fix a firmware for a 15 years old designs.
> And the Nut for it is without a configurator, no nutbld structure, output goes
> to source directories.
> Do you remember these times :-)?
>
My first patch is from 2006.

SNV/git however remebers those times.

How many sources are used? What about creating a .conf and and the new
build setup.

Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Thiago A. Corrêa
In reply to this post by Nikolas Becker
I wasn't following this conversation. I can make a binary with visual
studio compiler if you need. I don't usually rebuild the configurator
but never had problems building and running on windows.

On Thu, Mar 12, 2020 at 10:19 AM Nikolas Becker <[hidden email]> wrote:

>
> Hi Uwe,
>
> Thanks!
> I downloaded all the needed dlls (another one was missing: libwinpthread-1.dll). Now it tries to start but I get a similar error like when I tried to compile it myself:
> qnutconf.exe - Anwendungsfehler
> Die Anwendung konnte nicht korrekt gestartet werden (0xc000007b). Klicken sie auf "OK", um die Anwendung zu schließen.
>
> Any ideas?
>
> Bye,
>    Niko
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email] [mailto:[hidden email]] Im Auftrag von [hidden email]
> Gesendet: Donnerstag, 12. März 2020 13:48
> An: Ethernut User Chat (English) <[hidden email]>
> Betreff: Re: [En-Nut-Discussion] Working Windows build?
>
> Nikolas Becker writes:
> > Hi Uwe,
> >
> > I would be really happy if you would produce a win64/win32 version
> > (your choice). Stripping would be nice.
> > Thanks in advance!
> I have put them on tools/binaries/x86_64-w64-mingw32.
>
> nutconfigure starts in wine, qnutconf has dependancies not statified in my wine incarnation. I list the needed dll in Readme.md
>
> Please report back.
>
> Bye
> --
> Uwe Bonnes                [hidden email]
>
> Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
> --------- Tel. 06151 1623569 ------- Fax. 06151 1623305 --------- _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Nikolas Becker
Hi,

that would be nice!

Best regards,
   Nikolas

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Thiago A. Corrêa
Gesendet: Mittwoch, 18. März 2020 20:11
An: Ethernut User Chat (English) <[hidden email]>
Betreff: Re: [En-Nut-Discussion] Working Windows build?

I wasn't following this conversation. I can make a binary with visual studio compiler if you need. I don't usually rebuild the configurator but never had problems building and running on windows.

On Thu, Mar 12, 2020 at 10:19 AM Nikolas Becker <[hidden email]> wrote:

>
> Hi Uwe,
>
> Thanks!
> I downloaded all the needed dlls (another one was missing: libwinpthread-1.dll). Now it tries to start but I get a similar error like when I tried to compile it myself:
> qnutconf.exe - Anwendungsfehler
> Die Anwendung konnte nicht korrekt gestartet werden (0xc000007b). Klicken sie auf "OK", um die Anwendung zu schließen.
>
> Any ideas?
>
> Bye,
>    Niko
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email]
> [mailto:[hidden email]] Im Auftrag von
> [hidden email]
> Gesendet: Donnerstag, 12. März 2020 13:48
> An: Ethernut User Chat (English) <[hidden email]>
> Betreff: Re: [En-Nut-Discussion] Working Windows build?
>
> Nikolas Becker writes:
> > Hi Uwe,
> >
> > I would be really happy if you would produce a win64/win32 version
> > (your choice). Stripping would be nice.
> > Thanks in advance!
> I have put them on tools/binaries/x86_64-w64-mingw32.
>
> nutconfigure starts in wine, qnutconf has dependancies not statified
> in my wine incarnation. I list the needed dll in Readme.md
>
> Please report back.
>
> Bye
> --
> Uwe Bonnes                [hidden email]
>
> Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
> --------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
In reply to this post by Thiago A. Corrêa
Thiago A. Corrêa writes:
> I wasn't following this conversation. I can make a binary with visual
> studio compiler if you need. I don't usually rebuild the configurator
> but never had problems building and running on windows.
Please do so!

Thanks
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Thiago A. Corrêa
Hi,

    Took me a while to see the message, sorry for the delay. I have
uploaded to SF:
https://sourceforge.net/projects/ethernut/files/qnutconf-x64.zip/download
    Committed a really small fix for the build, just misisng a include
file when building on windows, I added an empty file to make the
compiler happy and it built.

    What I did:

     cd nut\tools\qnutconf
     mkdir build && cd build
     cmake .. -A x64
     cmake --build . --config Release
     windeployqt .\Release

Kind regards,
     Thiago A. Correa

On Thu, Mar 19, 2020 at 6:50 AM <[hidden email]> wrote:

>
> Thiago A. Corrêa writes:
> > I wasn't following this conversation. I can make a binary with visual
> > studio compiler if you need. I don't usually rebuild the configurator
> > but never had problems building and running on windows.
> Please do so!
>
> Thanks
> --
> Uwe Bonnes                [hidden email]
>
> Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
> --------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Nikolas Becker
Hi,

I just tried your compiled build. Thanks already!
I have the issue that the new build is not able to find my make.exe. It suggests an error in the Settings (Path variables) but I copied them from older versions where they are working properly. Do you get the same issue?

Best regards,
    Nikolas

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Thiago A. Corrêa
Gesendet: Freitag, 27. März 2020 17:45
An: Ethernut User Chat (English) <[hidden email]>
Betreff: Re: [En-Nut-Discussion] Working Windows build?

Hi,

    Took me a while to see the message, sorry for the delay. I have uploaded to SF:
https://sourceforge.net/projects/ethernut/files/qnutconf-x64.zip/download
    Committed a really small fix for the build, just misisng a include file when building on windows, I added an empty file to make the compiler happy and it built.

    What I did:

     cd nut\tools\qnutconf
     mkdir build && cd build
     cmake .. -A x64
     cmake --build . --config Release
     windeployqt .\Release

Kind regards,
     Thiago A. Correa

On Thu, Mar 19, 2020 at 6:50 AM <[hidden email]> wrote:

>
> Thiago A. Corrêa writes:
> > I wasn't following this conversation. I can make a binary with
> > visual studio compiler if you need. I don't usually rebuild the
> > configurator but never had problems building and running on windows.
> Please do so!
>
> Thanks
> --
> Uwe Bonnes                [hidden email]
>
> Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
> --------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Thiago A. Corrêa
I usually start the program from a prompt with the right environment
(path included).If there is a bug in the settings dialog we would have
to try to fix it.

On Mon, Mar 30, 2020 at 11:35 AM Nikolas Becker <[hidden email]> wrote:

>
> Hi,
>
> I just tried your compiled build. Thanks already!
> I have the issue that the new build is not able to find my make.exe. It suggests an error in the Settings (Path variables) but I copied them from older versions where they are working properly. Do you get the same issue?
>
> Best regards,
>     Nikolas
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Thiago A. Corrêa
> Gesendet: Freitag, 27. März 2020 17:45
> An: Ethernut User Chat (English) <[hidden email]>
> Betreff: Re: [En-Nut-Discussion] Working Windows build?
>
> Hi,
>
>     Took me a while to see the message, sorry for the delay. I have uploaded to SF:
> https://sourceforge.net/projects/ethernut/files/qnutconf-x64.zip/download
>     Committed a really small fix for the build, just misisng a include file when building on windows, I added an empty file to make the compiler happy and it built.
>
>     What I did:
>
>      cd nut\tools\qnutconf
>      mkdir build && cd build
>      cmake .. -A x64
>      cmake --build . --config Release
>      windeployqt .\Release
>
> Kind regards,
>      Thiago A. Correa
>
> On Thu, Mar 19, 2020 at 6:50 AM <[hidden email]> wrote:
> >
> > Thiago A. Corrêa writes:
> > > I wasn't following this conversation. I can make a binary with
> > > visual studio compiler if you need. I don't usually rebuild the
> > > configurator but never had problems building and running on windows.
> > Please do so!
> >
> > Thanks
> > --
> > Uwe Bonnes                [hidden email]
> >
> > Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
> > --------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
> > _______________________________________________
> > http://lists.egnite.de/mailman/listinfo/en-nut-discussion
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Nikolas Becker
I did the same, manually setting the PATH beforehand and running qnutconf from an administrator shell.
Now it tries to build but immediately stops:
09:56:31: makefile:38: D:/dev/trunk/Ethernut/ethernut_2020_03_30/nut/Makedefs.: No such file or directory
09:56:31: makefile:51: D:/dev/trunk/Ethernut/ethernut_2020_03_30/nut/Makerules.: No such file or directory
Here is my nut-Folder, copied out of the explorer, so this is for sure correct:
D:\dev\trunk\Ethernut\ethernut_2020_03_30\nut
And yes, the Makedefs. And Makerules.-files are there.
I tried to change the /-Signs to \-Signs, but that doesen't change anything.

So something is fishy with this build!

Best regards,
        Nikolas
   


-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Thiago A. Corrêa
Gesendet: Montag, 30. März 2020 22:12
An: Ethernut User Chat (English) <[hidden email]>
Betreff: Re: [En-Nut-Discussion] Working Windows build?

I usually start the program from a prompt with the right environment (path included).If there is a bug in the settings dialog we would have to try to fix it.

On Mon, Mar 30, 2020 at 11:35 AM Nikolas Becker <[hidden email]> wrote:

>
> Hi,
>
> I just tried your compiled build. Thanks already!
> I have the issue that the new build is not able to find my make.exe. It suggests an error in the Settings (Path variables) but I copied them from older versions where they are working properly. Do you get the same issue?
>
> Best regards,
>     Nikolas
>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email]
> [mailto:[hidden email]] Im Auftrag von Thiago A.
> Corrêa
> Gesendet: Freitag, 27. März 2020 17:45
> An: Ethernut User Chat (English) <[hidden email]>
> Betreff: Re: [En-Nut-Discussion] Working Windows build?
>
> Hi,
>
>     Took me a while to see the message, sorry for the delay. I have uploaded to SF:
> https://sourceforge.net/projects/ethernut/files/qnutconf-x64.zip/download
>     Committed a really small fix for the build, just misisng a include file when building on windows, I added an empty file to make the compiler happy and it built.
>
>     What I did:
>
>      cd nut\tools\qnutconf
>      mkdir build && cd build
>      cmake .. -A x64
>      cmake --build . --config Release
>      windeployqt .\Release
>
> Kind regards,
>      Thiago A. Correa
>
> On Thu, Mar 19, 2020 at 6:50 AM <[hidden email]> wrote:
> >
> > Thiago A. Corrêa writes:
> > > I wasn't following this conversation. I can make a binary with
> > > visual studio compiler if you need. I don't usually rebuild the
> > > configurator but never had problems building and running on windows.
> > Please do so!
> >
> > Thanks
> > --
> > Uwe Bonnes                [hidden email]
> >
> > Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
> > --------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
> > _______________________________________________
> > http://lists.egnite.de/mailman/listinfo/en-nut-discussion
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
> _______________________________________________
> http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
Nikolas Becker writes:
> I did the same, manually setting the PATH beforehand and running qnutconf from an administrator shell.
> Now it tries to build but immediately stops:
> 09:56:31: makefile:38: D:/dev/trunk/Ethernut/ethernut_2020_03_30/nut/Makedefs.: No such file or directory
> 09:56:31: makefile:51: D:/dev/trunk/Ethernut/ethernut_2020_03_30/nut/Makerules.: No such file or directory
> Here is my nut-Folder, copied out of the explorer, so this is for sure correct:
> D:\dev\trunk\Ethernut\ethernut_2020_03_30\nut
> And yes, the Makedefs. And Makerules.-files are there.
> I tried to change the /-Signs to \-Signs, but that doesen't change anything.
Please try first with some of the predefined STM32 conf files in nut/conf.

--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Nikolas Becker
I tried stm3210e-eval.conf and stm3240g-eval.conf. Always the same: the makedes and makerules cannot be found.
Besides, I currently want to build the predefined ethernut50f.conf file, since I use that board.

Best regards,
   Nikolas

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von [hidden email]
Gesendet: Dienstag, 31. März 2020 10:49
An: Ethernut User Chat (English) <[hidden email]>
Betreff: Re: [En-Nut-Discussion] Working Windows build?

Nikolas Becker writes:

> I did the same, manually setting the PATH beforehand and running qnutconf from an administrator shell.
> Now it tries to build but immediately stops:
> 09:56:31: makefile:38:
> D:/dev/trunk/Ethernut/ethernut_2020_03_30/nut/Makedefs.: No such file
> or directory
> 09:56:31: makefile:51:
> D:/dev/trunk/Ethernut/ethernut_2020_03_30/nut/Makerules.: No such file or directory Here is my nut-Folder, copied out of the explorer, so this is for sure correct:
> D:\dev\trunk\Ethernut\ethernut_2020_03_30\nut
> And yes, the Makedefs. And Makerules.-files are there.
> I tried to change the /-Signs to \-Signs, but that doesen't change anything.
Please try first with some of the predefined STM32 conf files in nut/conf.

--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 --------- _______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
Reply | Threaded
Open this post in threaded view
|

Re: Working Windows build?

Uwe Bonnes
Nikolas Becker writes:
> I tried stm3210e-eval.conf and stm3240g-eval.conf. Always the same:
> the makedes and makerules cannot be found.  
> Besides, I currently want to build the predefined ethernut50f.conf
> file, since I use that board.
>
Did you try pure nutconfigure? For a given configuration, nutconfigure
is the easiest way to go. qnutconf is only helpfull if you want to
setup/change a configuration in a graphical way with online help on
the configuration items.

It boils down to create the tree
$(NUTCONFIGURE) -c $(CONF) -s $(NUTSOURCE) -u . create-buildtree
$(NUTCONFIGURE) -c $(CONF) -s $(NUTSOURCE) -u . create-usertree

But anyway, the qnutconf issues should get fixed...

Bye
--
Uwe Bonnes                [hidden email]

Institut fuer Kernphysik  Schlossgartenstrasse 9  64289 Darmstadt
--------- Tel. 06151 1623569 ------- Fax. 06151 1623305 ---------
_______________________________________________
http://lists.egnite.de/mailman/listinfo/en-nut-discussion
12